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Avaya IPO10 IP PBX Configuration Document

 1 Introduction

These Application Notes describe the steps necessary for configuring Session Initiation Protocol (SIP) Trunking service between the legacy
Charter Communications Platform and an Avaya SIP-enabled enterprise solution. It does not provide any information how to provision, configure
or use the features of the switch. Please refer to the documentation provided with the IP PBX or contact the vendor.

1.1 Service Limitation

Charter Business has conducted thorough testing of the Avaya IP PBX and has determined that the combination of Charter Business SIP Trunks
and the Avaya IP-PBX   support consistent fax receipt or transmission. The customer should make alternative service arrangements inDOES NOT
order to support their faxing needs.

2 Configure IP Office

This section describes the IP Office configuration required to interwork with Charter SIP Trunking service. IP Office is configured through Avaya IP
Office Manager (IP Office Manager) which is a PC application.

Step Action Result

1 Navigate to Start > Programs > IP Office > Manager Launch IP Office Manager

2 Navigate to File > Open Configuration Pop-up Window Appears

3 Select The Proper IP Office

4 Log In With The Appropriate Credentials Management Window Appears

5 Go To Next Table

2.1 Licensing

The configuration and features described in these Application Notes require the IP Office system to be licensed appropriately. If a desired feature
is not enabled or there is insufficient capacity, contact an authorized Avaya sales representative

Step Action Result

6 Click:  in the  and  in the License Navigation Pane SIP Trunk Channels Group Pane

7 Confirm There Is A Valid License With Sufficient Instances (Trunk Channels) in the Details Pane

8 Procedure Complete
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2.2 System

 Configure the necessary system settings. In an Avaya IP Office, the LAN2 tab settings correspond to the Avaya IP Office WAN port (public
network side) and the LAN1 tab settings correspond to the LAN port (private network side). For the compliance test, the LAN1 interface was used
to connect Avaya IP Office to the enterprise private network (LAN), LAN2 was not used.

2.2.1 System - LAN1 Tab

In the sample configuration, I  was used as the system name. The  port connects to Charter’s Modular Access Router, acrossP500V2 Main LAN
the enterprise LAN (private) network. The  settings correspond to the LAN port in IP Office.LAN1

Step Action Result

1 To Access  Settings, Navigate to  in the LAN1 System(1) > IP5000V2 Main Navigation Pane  

2 In the  Navigate to the Details Pane LAN1 > LAN Settings Tab  

3 Set IP Address: LAN IP address, e.g. 10.64.70.60.  

4 Set IP Mask: LAN subnet mask, e.g. 255.255.255.0.  

5 All other parameeters should be set according to customer requirements  

6 Click:  to commitOK  

7 Go to Next Table  
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Step Action Result

8 Click On: VoIP Tab  

9 Check:  to allow Avaya IPH323 Gatekeeper Enable
Telephones/Softphone using the H.323 protocol to
register.

 

10 Check: to enable the configurationSIP Trunks Enable 
of SIP Trunk connecting to Charter.

 

11 Check:  to allow Avaya IPSIP Registrar Enable
Telephones/Softphone to register using the SIP
protocol.

 

12 Enter: the Domain Name of the enterprise under Doma
.in Name

 

13 Verify: the and  numbers under UDP Port TCP Port La
  are set to .yer 4 Protocol 5060

 

14 Verify: the  settings for a RTP Port Number Range
specific range for the RTP traffic.

The  and Port Range (Minimum) Port Range
 values were kept as default.(Maximum)

 

15 In the Keepalives Section, Set Scope: RTP-RTCP This will cause the IP Office to send RTP keepalive packets at the beginning
of the calls and every 30 seconds thereafter if no other RTP traffic is present.

16 Set Periodic Timeout: 30  

17 Set Initial Keepalives: Enabled  
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18 All other parameters should be set according to
customer requirements.

 

19 Click: OK to commit  

20 Go to Next Table  

 

 

 

Step Action Result

21 Click On: Network Topology Tab  

22 Select:  from the pull-down menu to the option thatFirewall/NAT Type
matches the network configuration. In the compliance testing, it was set to Op

.en Internet

With this configuration, even though the default STUN
settings are populated, they will not be used.

23 Set Binding Refresh Time (seconds): , the value of Desired Value 300 (or
was used during the compliance testing.every 5 minutes) 

This value is used to determine the  that IPfrequency
Office will send OPTIONS heartbeat to the service
provider.

23 Set Public IP address: The IP Address assigned under the LAN Settings
.tab, e.g., 10.64.70.60

 

24 Set Public Port: for 5060 UDP  
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25 All other parameters should be set according to customer requirements.  

26 Click:  to commitOK  

27 Go to Next Table  

 

 

2.2.2 - Telephony Tab

 

Step Action Result

28 Navigate to: Telephony > Telephony Tab in the Details Pane  

29 Choose: the typical for the enterpriseCompanding Law 
location, was used. U-Law 

 

30 Uncheck: Inhibit Off-Switch Forward/Transfer box  Allow call forwarding and call transfers to the PSTN via the SIP trunk
to the service provider.

31 All other parameters should be set according to customer
requirements.

 

32 Click:  to commitOK  

33 Go to Next Table  
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2.2.3 System - VoIP TAB

 

Step Action Result

34 Navigate To: System (1) > IP500V2 Main in the Navigation Pane  

35 Select: VoIP tab  

36 The  field is new in IP Office release 10. The default value  was used.RFC2833 Default Payload 101 It allows the manual
configuration of the payload
type used on SIP calls that are
initiated by the IP Office.

37 For  select the codecs and codec order of preference on the right, under the  Codec Selection: Select
 column. The area enables the codec preference order to be configureded Default Codec Selection 

on a system-wide basis. The buttons between the two lists can be used to move codecs between the 
 and  lists, and to change the order of the codecs in the  codecs list. TheUnused Selected Selected

example below shows the codecs used for IP phones (SIP and H.323), the system’s default codecs
and order was used.

By default, all IP lines and
phones (SIP and H.323) will
use the system default codec
selection shown here, unless
configured otherwise for a
specific line or extension.

38 Click:  to commitOK  

39 Procedure Completed  
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2.3 IP Route

In the reference configuration, the IP Office LAN1 interface and the private interface of the Charter’s Modular Access Router resided on the same
IP subnet, so an IP route was not necessary. In an actual customer configuration, these two interfaces may be in different IP subnets, and in that
case an IP route would have to be created to specify the IP address of the gateway or router where the IP Office needs to send the packets, in
order to reach the IP subnet where the Charter Modular Access Router resides.

To create an IP route to specify the IP address of the gateway or router where the IP Office needs to send the packets in order to reach the IP
subnet where the Charter’s Modular Access Router resides (if located in different subnets).

 

Step Action Result

1 In The Left , Right click on  > Select Navigation Pane IP Route New  

2 Set the and to  to make this the default route.IP Address IP Mask 0.0.0.0  

3 Set to the IP Address of the gateway/route used to route calls to the public network (to the networkGateway IP Address 
where Charter’s Modular Access Router resides, if located in different subnet), e.g., .10.64.70.1

 

4 Set to from the pull-down menuDestination LAN1  

5 Click:  to commitOK  

6 Procedure Completed  

 

<note>

Note: The codec selections defined under this section (System – VoIP Tab) are the codecs selected for the IP
phones/extensions. The codec selections defined under  (SIP Line – VoIP tab) are the codecs selected for theSection 2.4.6
SIP Line (Trunk).
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2.4 SIP Line

A SIP Line is needed to establish the SIP connection between IP Office and the Charter SIP Trunking Service. The recommended method for
configuring a SIP Line is to use the template associated with these Application Notes. The template is an .xml file that can be used by Avaya IP
Office Manager to create a SIP Line. Follow the steps in Sections 2.4.1 and 2.4.2 to create the SIP Line from the template.

Some items relevant to a specific customer environment are not included in the template or may need to be updated after the SIP Line is created.
Examples include the following:

IP addresses.
SIP trunk Registration Credentials.
SIP URI entries.
Setting of the Use Network Topology Info field on the Transport tab.

 

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary after the SIP Line is created via the template. The
resulting SIP Line data can be verified against the manual configuration shown in  to Section 2.4.3 2.4.7.

Alternatively, a SIP Line can be created manually. To do so, right-click on  in the  pane and select   . Then, followLine Navigation New à SIP Line
the steps outlined in  to Sections 2.4.3 2.4.7

 

2.4.1 Importing a SIP Line Template

 

<note>

Note: DevConnect generated SIP Line templates are always exported in an XML format. These XML templates do not
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Step Action Results

1 Copy a previously created template file to a location (e.g., C: ) on the\Temp
same computer where IP Office Manager is installed.

By default, the template file name will have the format <user supplied
, where the portion is entered duringtext>.xml  <user supplied text> 

template file creation.

 

2  

3 Import the template into IP Office Manager. From IP Office Manager,
select .Tools > Import Templates in Manager

A folder browser will open. Select the directory used to store the template(s) (e.g.,
C: ).\Temp

include sensitive customer specific information and are therefore suitable for distribution. The XML format templates can be
used to create SIP trunks on both IP Office Standard Edition (500v2) and IP Office Server Edition systems. Alternatively,
binary templates may be generated. However, binary templates include all the configuration parameters of the Trunk,
including sensitive customer specific information. Therefore, binary templates should only be used for cloning trunks within a
specific customer’s environment.

<note>

Note: If necessary, the portion <user supplied text>
of the template file name may be modified, however
the  format of the file  .xml<user supplied text>
name must be maintained.

For example, an original template file  could.xmlTest
be changed to . The template file name is.xmlTest1
selected in , , to create a newSection 5.4.2 step 1
SIP Line.
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4 In the reference configuration, template files  was CharterIPO10.xml
imported. The template files are automatically copied into the IP Office
default template location, C:\Program Files\Avaya\IP

.Office\Manager\Templates

 

5 After the import is complete, a final import status pop-up window will open
stating success or failure. Click .OK

 

6 Go To Next Table  

 

 

2.4.2 Creating a SIP Trunk From An XML Template

 

Step Action

7 To create the SIP Trunk from a template, right-click on  in the  pane, and select .Line Navigation New from Template > Open from file
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8 Navigate to (or C:\ \Avaya\IP Office\Manager\Templates), on theC:\Program Files\Avaya\IP Office\Manager\Templates Program Files (x86)
bottom right hand side chose  formatTemplate Files (*.xml)

and select the template, in this case  was selected.CharterIPO10.xml

9 After the import is complete, a final import status pop-up window will open stating success or failure. Click OK

10 Go To Next Table

 

 

 

 

2.4.3 SIP Line - SIP Line Tab

 

<note>

Note: It is important that the SIP Line configuration be reviewed and updated if necessary after the SIP Line is created via
the template. The resulting SIP Line data can be verified against the manual configuration shown in   to  . Sections 2.4.3 2.4.7
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Step Action Results

11 Click on the  tab in the  paneSIP Line Details  

12 Leave the  blankITSP Domain Name If this field is left blank, then IP Office inserts the ITSP Proxy Address from the
Transport tab as the ITSP Domain in the SIP messaging.

13 Verify that  is set to URI Type SIP  

14 Verify that  box is checked, which is theIn Service
default value

This makes the trunk available to incoming and outgoing calls.

15 Verify that  box is checked, the defaultCheck OOS
value.

IP Office will use the SIP OPTIONS method to periodically check the SIP Line.
The time between SIP OPTIONS sent by IP Office will use the Binding Refresh
Time for LAN1, as shown in . Section 2.2.1

16 Verify that  is set to .Refresh Method Auto  

17 Verify that  is set to Timer (seconds) On Demand  

18 Under , set Redirect and Transfer Incoming
and Supervised REFER Outgoing Supervised

 to  (see ).REFER Never Sections 2.1

 

19 All other parameters should be set to default or
according to customer requirements. 

 

20 Click  to commit OK  

21 Go to Next Table  

 

 

2.4.4 SIP Line - Transport Tab

 

Step Action Results

22 Click on the  tab in the  paneTransport Details  
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23 Set the  to the IP address of the inside interface (or private side) assigned to Charter’s ModularITSP Proxy Address
Access Router.

 

24 Set the to . Layer 4 Protocol UDP  

25 Set to as configured in . Use Network Topology Info LAN1 Section 2.2  

26 Set the to .Send Port 5060  

27 All other parameters should be set to default or according to customer requirements.   

28 Click  to commit OK  

29 Go to Next Table  

 

 

 

2.4.5 SIP Line - SIP URI Tab

A SIP URI entry needs to be created to match each incoming number that IP Office will accept on this line.

Step Action Results

30 In the SIP URI Tab click Add The area will appear at the bottom of the pane. New Channel 

31 To edit an existing entry, click an entry in the list at the top, and
click the button.Edit 

 

32 Set , , to .Local URI Contact  Display Name Use Internal Data  

33 Set  under  to .Identity Identity Auto  

34 Set  under  to Header Identity P Asserted ID  

35 Set  under  to Send Caller ID Forwarding and Twinning Diversi
.on Header

 

36 Set  to .Diversion Header Auto  

37 Associate this line with an incoming line group by entering a line
group number in the field.Incoming Group 

 This line group number will be used in defining incoming call routes
for this line. 
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38 Associate the line to an outgoing line group using the Outgoing
field.Group 

The outgoing line group number is used in defining short codes for
routing outbound traffic to this line.

For the compliance test, a new incoming and outgoing group wa17 
s defined that only contains this line (line 17). 

39 Set to the number of simultaneous SIP calls thatMax Sessions 
are allowed using this SIP URI pattern.

 

40 Click  to commitOK  

41 Click  to commit againOK  

42 Go to Next Table  

 

 

2.4.6 SIP Line -VoIP Tab

 

Step Action Results

43 Select the  to set the Voice over Internet Protocol Parameters of the SIP LineVoIP tab The area will appear atNew Channel 
the bottom of the pane. 

44 In the sample configuration, the was configured using the  optionCodec Selection Custom
, allowing an explicit order of codecs to be specified for the SIP Line. The buttons allow
setting the specific order of preference for the codecs to be used on the SIP Line, as
shown. Charter only supports codec G.711ULAW for audio.

 

45 Select G.711 for  (Refer to ). Fax Transport Support Section 2.1  

46 Set the field to DTMF Support RFC2833 .  This directs Avaya IP Office to send
DTMF tones using RTP events
messages as defined in RFC2833.

47 Check the boxRe-invite Supported  Allow for codec re-negotiation in cases
where the target of an incoming call or
transfer does not support the codec
originally negotiated on the trunk.

48 Check the  boxPRACK/100rel Supported Advertise the support for reliable
provisional responses and Early Media
to Charter.

49 Set  to .Diversion Header Auto  

50 Default values may be used for all other parameters.  

51 Click  to commitOK  

52 Go to Next Table  
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2.4.7 SIP Line - SIP Advanced Tab

Step Action Results

53 Select the SIP
 toAdvanced tab

configure IP Office to
use the PAI header for
privacy calls

For outbound calls with privacy enabled, Avaya IP Office will replace the calling party number in the From and
Contact headers of the SIP INVITE message with “anonymous”. IP Office can be configured to use the
P-Preferred-Identity (PPI) or P-Asserted-Identity (PAI) header to pass the actual calling party information for
authentication and billing purposes. By default, IP Office will use the PPI header for privacy.

54 Verify the Call
isRouting Method 

set to .Request URI

 

55 Check the box for Use
.PAI for Privacy

 

56 Default values may be
used for all other
parameters.

 

57 Click  to commitOK  

58 Procedure Completed  

 

<note>

Note: The codec selections defined under this section (SIP Line – VoIP tab) are the codecs selected for the SIP Line
(Trunk). The codec selections defined under Section 2.2.3 (System – VoIP tab) are the codecs selected for the IP
phones/extension (H.323 and SIP).
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2.5 Extension

In this section, an example of an Avaya IP Office Extension will be illustrated. In the interest of brevity, not all users and extensions will be
presented, since the configuration can be easily extrapolated to other users and extensions.

Step Action Results

1 Right click on Extension  

2 Select Select  orNew >  H323  SIP  

3 Select the  TabExtension  

4 Go to Next Table  

 

Following is an example of extension 1502; this extension corresponds to an H.323 extension:



The information contained herein is confidential and should not be disclosed, copied, or duplicated in any manner without written
permission from Charter Communications™.

17

 

 

 

Step Action Results

5 Select the V
 tabOIP

 

6 Use default
values on V

taboIP 

By default, all IP phones (SIP and H.323) will use the system default codec selection configured under the System VoIP
tab ( ), unless configured otherwise for a specific extension by selecting  under  oSection 2.2.3 Custom Codec Selection
n the screenshot shown below. 

7 Procedure
Completed

 

 

The example below shows the codecs used for IP phones (SIP and H.323).
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2.6 Users

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP line defined in .Section 2.4

Step Action Results

1 Navigate to  in the left  paneUser Navigation  

2 Select the name of the user to be modified in the center  paneGroup  

3 Go to Next Table  

 

In the example below, the name of the user is “H323 Ext 1502”:
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In the example below, the name of the user is “Soft SIP 1550”.

Step Action Results

4 This is an Avaya IP Office Softphone user, set the Profile to   Power User  

5 Ceck Enable Softphone  

6 Go to Next Table  
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Step Action Results

7 Select the Voic
 Tabemail

The screen shows the tab for the user with extension 1502. Voicemail password can be configured usingVoicemail 
the  and parameters.Voicemail Code Confirm Voicemail Code 

In the verification of these Application Notes, incoming calls from Charter to this user were redirected to Voicemail
Pro after no answer. Voicemail messages were recorded and retrieved

successfully. Voice mail navigation and retrieval were performed locally and from PSTN telephones to test DTMF
using RFC 2833.

8 Go to Next
Table
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Step Action Results

9 Select the  tabMobility  

10 Check  boxMobility Features  

11 Check  boxMobile Twinning  

12 Configure field with the number to dial to reach the twinned telephone,Twinned Mobile Number 

including the dial access code “9”, in this case .917864571234

 

13 Other options can be set according to customer requirements  

14 Go to next Table  
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Step Action Results

15 Select the  tab on the userButton Programming  

16 select the   to turn Mobil Twinningbutton to program
on and off

 

17 Click on Edit > Emulation > Twinning In the sample below, button  was programmed to turn Mobil Twinning on and4
off on user 1502. 

18 Go to next Table  
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Step Action Results

19 Select tabSIP  the values entered for the and fields are used asSIP Name Contact 
the user part of the SIP URI in the “From” and “Contact” headers for
outgoing SIP trunk calls.

In addition, these settings are used to match against the SIP URI of
incoming calls without having to enter this number as an explicit SIP
URI for the SIP line ( )Section 2.4

20 The and are set to one of the DID numbersSIP Name Contact 
assigned to the enterprise by Charter.

 In the example, DID number  was used. 3031231273

21 The parameter can optionally beSIP Display Name (Alias) 
configured with a descriptive name. 

 

22 If all calls involving this user should be considered private, then
the box may be checked to withhold the Caller IDAnonymous 
information from the network.

 

23 Procedure Completed  

 



The information contained herein is confidential and should not be disclosed, copied, or duplicated in any manner without written
permission from Charter Communications™.

24

 

2.7 Incoming Call Route

An incoming call route maps inbound DID numbers on a specific line to internal extensions, hunt groups, short codes, etc., within the IP Office
system.

In a scenario like the one used for the compliance test, only one incoming route is needed, which allows any incoming number arriving on the SIP
trunk to reach any predefined extension in IP Office. The routing decision for the call is based on the parameters previously configured for Call

and and the users and , already populated with the assigned Charter DID numbersRouting Method  SIP URI (Section 2.4.5) SIP Name  Contact  
.(Section 2.6)

 

Step Action Results

1 From the left  pane, right-click on and select .Navigation Incoming Call Route New  

2 On the  pane (not shown), Select the  tabDetails Standard  

3 Set  to .  Bearer Capacity Any Voice  

4 Set the to the incoming line group of the SIP line defined in . Line Group ID Section 5.4  

5 Default values may be used for all other parameters.  

6 Go to Next Table  
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Step Action Results

7 Under the tab, enter “ ” forDestinations .
the . Default Value

This setting will allow the call to be routed to any destination with a value on its  fSIP Name
ield, entered on the tab of that SIP User,

which matches the number present on the user part of the incoming Request URI. 

8 Click  to commitOK  

9 Procedure Completed  
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2.8 Outbound Call Routing

For outbound call routing, a combination of system short codes and Automatic Route Selection (ARS) entries are used. With ARS, features like
time-based routing criteria and alternate routing can be specified so that a call can re-route automatically if the primary route or outgoing line
group is not available. While detailed coverage of ARS is beyond the scope of these Application Notes, and alternate routing was not used in the
reference configuration, this section includes some basic screen illustrations of the ARS settings used during the compliance testing.

 

2.8.1 Short Codes and Automatic Route Selection

Step Action Results

1 To create the short code used for ARS right-click on  inShort Code
the pane Navigation 

 

2 Select New The screen below shows the creation of the short code  use9N
d in the reference configuration.

When the Avaya IP Office users dialed 9 plus any number N,
calls were directed to  which configurable via Line Group 17
ARS.

3 In the  field, enter the dial string which will trigger this shortCode
code. In this case, was used (note that the semi-colon is not used9N 
here).

 

4 Set  to . Feature Dial This is the action that the short code will perform.

5 Set  to .Telephone Number N The value N represents the number dialed by the user after
removing the 9 prefix. This value is passed to ARS.

6 Set the  to  to be directed to ,Line Group ID 50: Main  Line Group 17
which is configurable via ARS.

 

7 Set the Locale to .United States (US English)  

8 Click the  to commit.OK  

9 Go to Next Table  
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The following screen shows a sample ARS configuration for the route  . Note the sequence of ’s used in the  field of the entries to50: Main X Code
specify the exact number of digits to be expected, following the access code and the first set of digits on the string. This type of setting results in a
much quicker response in the delivery of the call by IP Office.

 

Step Action Results

10 To create a short code to be used for ARS, select > on the ARS 50: Main 
 pane Navigation

 

11 Select New  

12 In the  field, enter the dial string which will trigger this short code. InCode
this case, followed by ’s to represent the exact number of digits.1 10 X

 

13 Set  to . Feature Dial This is the action that the short code will perform.

14 Set  to .Telephone Number 1N The value N represents the additional number of digits
dialed by the user after dialing 1 (The 9 will be stripped
off).

15 Set the  to the Line Group number being used for the SIPLine Group ID
Line, in this case Line  was used.Group ID 17

 

16 Set the Locale to .United States (US English)  

17 Click the  to commit.OK  

18 Procedure Completed  

 

 

 

The following screenshot shows the ARS dial pattern entry after it was added.
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2.9 Save Configuration

When desired, send the configuration changes made in Avaya IP Office Manager to the Avaya IP Office server in order for the changes to take
effect.

Step Action Result

1 Navigate to File > Save
 in the menuConfiguration

bar at the top left of the
screen

Save the configuration performed in the preceding sections.

Once the configuration is validated, a screen similar to the following will appear, with either the  orMerge
the radio button chosen based on the nature of the configuration changes made since theImmediate  
last save. Note that clicking OK may cause a service disruption due to system reboot.

2 Click  if desiredOK  

3 Procedure Completed  
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