About Spectrum Enterprise:

Spectrum Enterprise is a division of Charter Communications following a merger with Time Warner Cable and acquisition of Bright House Networks. Spectrum Enterprise is a national provider of scalable, fiber technology solutions. The Spectrum Enterprise portfolio includes networking and managed services solutions, including Internet access, Ethernet and Managed Network Services, Voice, TV and Cloud solutions. Our industry-leading team of experts works closely with clients to achieve greater business success.

About this document:

Spectrum Enterprise assures IP PBX compatibility by conducting interoperability testing to ensure any potential compatibility issues have been resolved prior to installation. Please review the IP PBX configuration instructions in this guide prior to your installation date.

Be advised that this document may contain references to Time Warner Cable Business Class. All references to Time Warner Cable Business Class, TWCBC or TWC should be read as Spectrum Enterprise.

Thank you,

Spectrum Enterprise
Abstract

These Application Notes describe the steps necessary for configuring Session Initiation Protocol (SIP) Trunk Service for an enterprise solution consisting of Avaya IP Office Release 9.1 to interoperate with Time Warner Cable Business Class SIP Trunking Service.

The test was performed to verify SIP trunk features including basic calls, call forward (all calls, busy, no answer), call transfer (blind and consult), conference, and voice mail. The calls were placed to and from the PSTN with various Avaya endpoints.

Time Warner Cable Business Class SIP Trunking Service provides PSTN access via a SIP trunk between the enterprise and Time Warner Cable’s network as an alternative to legacy analog or digital trunks. This approach generally results in lower cost for the enterprise.

Readers should pay attention to Section 2, in particular the scope of testing as outlined in Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases are adequately covered by this scope and results.

Time Warner Cable is a member of the Avaya DevConnect Service Provider Program. Information in these Application Notes has been obtained through DevConnect compliance testing and additional technical discussions. Testing was conducted via the DevConnect Program at the Avaya Solution and Interoperability Test Lab.
1. Introduction

These Application Notes describe the steps necessary for configuring Session Initiation Protocol (SIP) Trunk Service for an enterprise solution consisting of Avaya IP Office Release 9.1 to interoperate with Time Warner Cable Business Class SIP Trunking Service.

In the sample configuration, the Avaya IP Office solution consists of Avaya IP Office (hereafter referred to as IP Office) 500v2 Release 9.1 and various Avaya endpoints, including Avaya Communicator for Windows and Avaya deskphones, including SIP, H.323, digital, and analog.

The terms “Service Provider” and “Time Warner Cable” will be used interchangeable throughout these Application Notes.

The Time Warner Cable Business Class SIP Trunking Service referenced within these Application Notes is designed for business customers. Customers using this service with the IP Office solution are able to place and receive PSTN calls via a broadband WAN connection using the SIP protocol. This converged network solution is an alternative to traditional PSTN trunks such as analog and/or ISDN-PRI trunks. This approach generally results in lower cost for the enterprise.

2. General Test Approach and Test Results

The general test approach was to connect a simulated enterprise site to Time Warner Cable’s network via the public Internet and exercise the features and functionalities listed in Section 2.1. The simulated enterprise site was comprised of IP Office Release 9.1 and various Avaya endpoints, listed in Section 4.

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent to the interoperability of the tested products and their functionalities. DevConnect Compliance Testing is not intended to substitute full product performance or feature testing performed by DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or completeness of a DevConnect member’s solution.

2.1. Interoperability Compliance Testing

To verify SIP trunk interoperability, the following features and functionalities were covered during the interoperability compliance test:

- SIP Trunk Registration (Dynamic Authentication).
- SIP OPTIONS queries and responses.
- Incoming calls from the PSTN were routed to the DID numbers assigned by Time Warner Cable. Incoming PSTN calls were terminated to the following endpoints: Avaya 96x0 Series IP Deskphones (H.323), Avaya 96x1 Series IP Deskphones (H.323), Avaya 1100 Series IP Deskphones (SIP), Avaya Communicator for Windows, Avaya 1400 Series Digital Deskphones, Avaya 9500 Series Digital Deskphones, and analog Deskphones.
• Outgoing calls to the PSTN were routed via Time Warner Cable’s network to the various PSTN destinations.
• Caller ID presentation.
• Proper disconnect when the caller abandons the call before the call is answered.
• Proper disconnect via normal call termination by the caller or the called parties.
• Proper disconnect by the network for calls that are not answered (with voicemail off).
• Proper response to busy endpoints.
• Proper response/error treatment when dialing invalid PSTN numbers.
• Codec G.711MU (Time Warner Cable supported audio codec).
• No matching codecs.
• G.711 fax pass-through.
• Proper early media transmissions.
• Voicemail and DTMF tone support (leaving and retrieving voice mail messages from PSTN phones).
• Outbound Toll-Free calls, interacting with IVR (Interactive Voice Response systems).
• Calling number blocking (Privacy).
• Call Hold/Resume (long and short duration).
• Call Forward (unconditional, busy, no answer).
• Blind Call Transfers.
• Consultative Call Transfers.
• Station Conference.
• Mobility twinning of incoming calls to mobile phones.
• Simultaneous active calls.
• Long duration calls (over one hour).
• Proper response/error treatment to all trunks busy.
• Proper response/error treatment when disabling SIP connection.

**Note:** Remote worker was not tested with this solution since the Avaya Session Border Controller for Enterprise (Avaya SBCE) was not included in the configuration used during the compliance testing. The Avaya SBCE is a required component for enterprises planning to deploy Remote Workers.

Items not supported or not tested included the following:
• Time Warner Cable does not support T.38 fax; therefore T.38 fax was not tested (G.711 fax pass-through was tested successfully).
• The use of the SIP REFER method for network call redirection is not currently supported by Time Warner Cable; therefore SIP REFER was not tested.
• Inbound toll-free calls, 911 emergency and International calls are supported but were not tested.
2.2. Test Results

Interoperability testing of Time Warner Cable Business Class SIP Trunking Service was completed with successful results for all test cases with the exception of the observations/limitations described below.

- **Consultative Transfer to the PSTN by Avaya Communicator for Windows**: Calls from the PSTN to an Avaya Communicator for Windows softphone user in IP Office that are transferred back to the PSTN via a consultative (attended) transfer failed to complete. This issue is only seen with Service Providers that challenge every call using Digest Authentication and in cases where SIP REFER is not supported by the Service Provider. This issue was only seen with the Avaya Communicator for Windows softphone, other Avaya endpoints used during the testing worked properly. A ticket was opened against IP Office; this issue is under investigation by Avaya.

2.3. Support

For support on Time Warner Cable systems visit the corporate Web page at: [http://business.timewarnercable.com/support/overview.html or call 866-892-4249](http://business.timewarnercable.com/support/overview.html).
3. Reference Configuration

Figure 1 illustrates the test configuration used for the DevConnect compliance testing. The test configuration simulates an enterprise site with an Avaya SIP-enabled enterprise solution connected to the Time Warner Cable Business Class SIP Trunking Service through the public Internet.

The Avaya components used to create the simulated enterprise customer site includes:

- Avaya IP Office 500v2.
- Avaya Voicemail Pro for IP Office.
- Avaya 96x0 Series H.323 IP Deskphones.
- Avaya 96x1 Series H.323 IP Deskphones.
- Avaya 1100 Series SIP IP Deskphones.
- Avaya Communicator for Windows Softphone.
- Avaya 1408 Digital Deskphones.
- Avaya 9508 Digital Deskphones.
- Analog Deskphone.
- Fax Machines.

The enterprise site contains the Avaya IP Office 500v2 with analog and digital extension expansion modules, as well as a VCM64 (Voice Compression Module) for supporting VoIP codecs. The LAN1 port of IP Office is connected to the enterprise LAN (private IP network) while the LAN2 port is connected to the public IP network. Endpoints include Avaya 96x0 and 96x1 Series IP Deskphones (with H.323 firmware), Avaya 1100 Series IP Deskphones (with SIP firmware), Avaya 1408 and 9508 Digital Deskphones, Analog Deskphones, Fax Machines, and PC running Avaya Communicator for Windows Softphone. The site also has a Windows PC running Avaya IP Office Manager to configure and administer the IP Office system, and Avaya Voicemail Pro providing voice messaging service to the IP Office users. Mobile Twinning is configured for some of the IP Office users so that calls to these user’s extensions will also ring and can be answered at the configured mobile phones.

For the purposes of the compliance test, users dialed a short code of 9 + N digits to make calls across the SIP trunk to Time Warner Cable. The short code 9 was stripped off by IP Office but the remaining “N” digits were sent unaltered to the network. Refer to Section 5.5.

In an actual customer configuration, the enterprise site may include additional network components between the service provider and the IP Office system, such as a session border controller or data firewall. A complete discussion of the configuration of these devices is beyond the scope of these Application Notes. However, it should be noted that all SIP and RTP traffic between the service provider and the IP Office system must be allowed to pass through these devices.
For confidentiality and privacy purposes, public IP addresses, user names, passwords and DID numbers used during the compliance testing have been masked.

Figure 1: Avaya Interoperability Test Lab Configuration
## 4. Equipment and Software Validated

The following equipment and software were used for the sample configuration provided:

<table>
<thead>
<tr>
<th>Equipment/Software</th>
<th>Release/Version</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Avaya</strong></td>
<td></td>
</tr>
<tr>
<td>Avaya IP Office 500v2</td>
<td>9.1.0.0 Build 437</td>
</tr>
<tr>
<td>Avaya IP Office DIG DCPx16 V2</td>
<td>9.1.0.0 Build 437</td>
</tr>
<tr>
<td>Avaya IP Office Manager</td>
<td>9.1.0.0 Build 437</td>
</tr>
<tr>
<td>Avaya Voicemail Pro Client</td>
<td>9.1.0.0 Build 166</td>
</tr>
<tr>
<td>Avaya 96x0 Series IP Deskphones (H.323)</td>
<td>Avaya one-X® Deskphone Edition S3.230A</td>
</tr>
<tr>
<td>Avaya 96x1 Series IP Deskphones (H.323)</td>
<td>Avaya one-X® Deskphone H.323</td>
</tr>
<tr>
<td></td>
<td>Version 6.4014</td>
</tr>
<tr>
<td>Avaya 1140E IP Deskphones (SIP)</td>
<td>SIP1140e Ver. 04.04.18.00</td>
</tr>
<tr>
<td>Avaya Communicator for Windows</td>
<td>2.0.3.30</td>
</tr>
<tr>
<td>Avaya Digital Deskphones 1408</td>
<td>40.0</td>
</tr>
<tr>
<td>Avaya Digital Deskphones 9508</td>
<td>0.55</td>
</tr>
<tr>
<td>Lucent Analog Phone</td>
<td>--</td>
</tr>
</tbody>
</table>

| **Time Warner Cable**                       |                                  |
| Nokia Solutions and Networks (NSN) IMS CSCF | 8.2EP2                           |
| Innomedia ESBC                              | 2.0.13.0                         |

**Note:** Compliance Testing is applicable when the tested solution is deployed with a standalone IP Office 500 V2 and also when deployed with all configurations of IP Office Server Edition without T.38 Fax Service.
5. Configure Avaya IP Office

IP Office is configured through the Avaya IP Office Manager application. From the PC running Avaya IP Office Manager, select Start → Programs → IP Office → Manager to launch the application. A screen that includes the following may be displayed.

Select Open Configuration from System. If the above screen does not appear, the configuration may be alternatively opened by navigating to File → Open Configuration at the top of the Avaya IP Office Manager window. Select the proper IP Office system from the pop-up window and log in with the appropriate credentials.

The appearance of the Avaya IP Office Manager can be customized using the View menu. In the screens presented in this document, the View menu was configured to show the Navigation pane on the left side, omit the Group pane in the center, and show the Details pane on the right side. Since the Group pane has been omitted, its content is shown as submenus in the Navigation pane. These panes (Navigation, Group and Details) will be referenced throughout the IP Office configuration. All licensing and feature configuration that is not directly related to the interface with the service provider is assumed to already be in place.

In the sample configuration, the MAC address 00E00706530F was used as the system name. All navigation described in the following sections (e.g., License → SIP Trunk Channels) appears as submenus underneath the system name 00E00706530F in the Navigation Pane.
5.1. Licensing and Physical Hardware

The configuration and features described in these Application Notes require IP Office to be licensed appropriately. If a desired feature is not enabled or there is insufficient capacity, contact an authorized Avaya sales representative.

To verify that there is a SIP trunk channels license with sufficient capacity, click License in the Navigation pane. Confirm a valid license with sufficient Instances (trunk channels) in the Details pane. Note that the full License Key in the screen below is not shown for security purposes.
To view the physical hardware comprising IP Office, expand the components under the **Control Unit** in the Navigation pane. In the sample configuration, the Avaya IP Office 500v2 is equipped with analog and digital extension expansion modules, as well as a VCM64 (Voice Compression Module) for supporting VoIP codecs. An IP Office hardware configuration with a VCM component is necessary to support SIP Trunking Services.

To view the details of the component, select the component in the Navigation pane. The following screen shows the details of the **Avaya IP 500 V2**.
5.2. System
Configure the necessary system settings. In an IP Office, the LAN2 tab settings correspond to the IP Office WAN port (public network side) and the LAN1 tab settings correspond to the LAN port (private network side).

5.2.1. System – LAN2 Tab
In the sample configuration, the IP Office WAN port was used to connect to Time Warner Cable. The LAN2 settings correspond to the WAN port on the Avaya IP Office 500v2. To access the LAN2 settings, first navigate to System → <Name>, where <Name> is the system name assigned to IP Office. In the case of the compliance test, the system name is the MAC address 00E00706530F. Next, navigate to the LAN2 → LAN Settings tab in the Details Pane. Set the IP Address field to the public IP address assigned to the IP Office WAN port. Set the IP Mask field to the mask used with the public IP address. All other parameters should be set to default or according to customer requirements. Click OK to commit (not shown).
On the VoIP tab in the Details Pane, configure the following parameters:

- Check the **SIP Trunks Enable** box to enable the configuration of SIP trunks.
- The **RTP Port Number Range** can be customized to a specific range of receive ports for RTP media. Based on this setting, IP Office would request RTP media be sent to a UDP port in the configurable range for calls using LAN2.
Scroll down the page.

- In the **RTP Keepalives** section, set the **Scope** to **RTP**. Set the **Periodic timeout** to **30** and the **Initial keepalives** parameter to **Enabled**. These settings will cause IP Office to send a RTP keepalive packet starting at the time of initial connection and every 30 seconds thereafter if no other RTP traffic is present. This facilitates the flow of media in cases where each end of the connection is waiting to see media from the other, as well as helping to keep firewall ports open for the duration of the call.

- In the **DiffServ Settings** section, IP Office can also be configured to mark the Differentiated Services Code Point (DSCP) in the IP Header with specific values to support Quality of Services policies for both signaling and media. The **DSCP** field is the value used for media and the **SIG DSCP** is the value used for signaling. The specific values used for the compliance test are shown in the example below and are also the default values. For a customer installation, if the default values are not sufficient, appropriate values will be provided by the customer.

- All other parameters should be set to default or according to customer requirements.
- Click **OK** to commit (not shown).
On the **Network Topology** tab in the Details Pane, configure the following parameters:

- **Select the Firewall/NAT Type** from the pull-down menu that matches the network configuration. Since no firewall or network address translation (NAT) device was used between IP Office and the Time Warner Cable, the parameter was set to **Open Internet**.
- **Set the Binding Refresh Time (seconds)** to a desired value, the value of **300 (or every 5 minutes)** was used during the compliance testing. This value is used to determine the frequency that IP Office will send OPTIONS heartbeat to the service provider.
- **Set Public IP Address** to the IP address of the IP Office WAN port.
- **In the Public Port section**, next to the transport protocol **UDP**, select the UDP port on which IP Office will listen.
- **All other parameters should be set to default or according to customer requirements**.
- **Click OK to commit (not shown)**.

**Note:** In the compliance test, the LAN1 interface was used to connect IP Office to the enterprise site IP network (private network). The LAN1 interface configuration is not directly relevant to the interface with the Time Warner Cable SIP Trunking Service, and therefore is not described in these Application Notes.
5.2.2. System - Telephony Tab

To access the System Telephony settings, navigate to the Telephony → Telephony tab in the Details Pane. Uncheck the Inhibit Off-Switch Forward/Transfer box to allow call forwarding and call transfer to the PSTN. If for security reasons incoming calls should not be allowed to transfer back to the PSTN then leave this setting checked. All other parameters should be set to default or according to customer requirements. Click OK to commit (not shown).
5.2.3. System - Twinning Tab

To view or change the System Twinning settings, navigate to the Twinning tab in the Details Pane as shown in the following screen. The Send original calling party information for Mobile Twinning box is not checked in the sample configuration, and the Calling party information for Mobile Twinning is left blank. Click OK to commit (not shown).
5.2.4. System – Codecs Tab

- In the Codecs tab of the Details Pane, select or enter 101 for RFC2833 Default Payload. This setting was recommended by Time Warner Cable for use with out-band DTMF tone transmissions.
- For codec selection, select the codecs and codec order of preference on the right, under the Selected column. The Default Codec Selection area enables the codec preference order to be configured on a system-wide basis. The buttons between the two lists can be used to move codecs between the Unused and Selected lists, and to change the order of the codecs in the Selected codecs list. By default, all IP phones (SIP and H.323) will use the system default codec selection shown here, unless configured otherwise for a specific extension. The example below shows the codecs used for IP phones (SIP and H.323); specifically, codec G.711ULAW was used during the compliance testing.

![Codec Selection](image)

Note: The codec selections defined under this section (System – Codecs Tab) are the codecs selected for the IP phones/extensions. The codec selections defined under Section 5.4.6 (SIP Line – VoIP tab) are the codecs selected for the SIP Line (Trunk).
5.3. IP Route

Create an IP route to specify the IP address of the gateway or router where IP Office needs to send the packets in order to route calls to Time Warner Cable’s network (if located in a different subnet).

To create an IP route, on the left navigation pane, right-click on IP Route. Select New (not shown).

- Set IP Address to 10.10.112.0.
- Set the IP Mask to 255.255.255.0.
- Set Gateway IP Address to the IP address of the default router for the public network where IP Office is connected.
- Set Destination to LAN2 from the drop-down list.
- Click the OK to commit (not shown).
5.4. SIP Line

A SIP Line is needed to establish the SIP connection between IP Office and Time Warner Cable Business Class SIP Trunking Service. The recommended method for configuring a SIP Line is to use the template associated with these Application Notes. The template is an .xml file that can be used by Avaya IP Office Manager to create a SIP Line. Follow the steps in Sections 5.4.1 and 5.4.2 to create the SIP Line from the template.

Some items relevant to a specific customer environment are not included in the template or may need to be updated after the SIP Line is created. Examples include the following:

- IP addresses.
- SIP trunk Registration Credentials.
- SIP URI entries.
- Setting of the Use Network Topology Info field on the Transport tab.

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary after the SIP Line is created via the template. The resulting SIP Line data can be verified against the manual configuration shown in Section 5.4.3 – 5.4.8.

Alternatively, a SIP Line can be created manually. To do so, right-click on Line in the Navigation Pane and select New → SIP Line. Then, follow the steps outlined in Section 5.4.3 – 5.4.8.

5.4.1. Importing a SIP Line Template

**Note** – DevConnect generated SIP Line templates are always exported in an XML format. These XML templates do not include sensitive customer specific information and are therefore suitable for distribution. The XML format templates can be used to create SIP trunks on both IP Office Standard Edition (500v2) and IP Office Server Edition systems. Alternatively, binary templates may be generated. However, binary templates include all the configuration parameters of the Trunk, including sensitive customer specific information. Therefore, binary templates should only be used for cloning trunks within a specific customer’s environment.

1. Copy a previously created template file to a location (e.g., C:\Temp) on the same computer where IP Office Manager is installed. By default, the template file name will have the format **AF_<user supplied text>_SIPTrunk.xml**, where the **<user supplied text>** portion is entered during template file creation.

**Note** – If necessary, the **<user supplied text>** portion of the template file name may be modified, however the **AF_<user supplied text>_SIPTrunk.xml** format of the file name must be maintained. For example, an original template file **AF_TEST_SIPTrunk.xml** could be changed to **AF_Test1_SIPTrunk.xml**. The template file name is selected in Section 5.4.2, step 2, to create a new SIP Line.
2. Verify that Template Options are enabled in IP Office Manager. In IP Office Manager, navigate to **File ➔ Preferences**. In the IP Office Manager Preferences window that appears, select the **Visual Preferences** tab. Check the box next to **Enable Template Options**. Click **OK**.

![IP Office Manager Preferences](image1.png)

3. Import the template into IP Office Manager. From IP Office Manager, select **Tools ➔ Import Templates in Manager**.

![Import Templates in Manager](image2.png)
4. A folder browser will open. Select the directory used in **step 1** to store the template(s) (e.g., \C:\Temp).

![Screenshot of Browse For Folder window](image)

In the reference configuration, template files **AF_TWC without Avaya SBCE_ S1PTrunk.xml** was imported. The template files are automatically copied into the IP Office default template location, **C:\Program Files\Avaya\IP Office\Manager\Templates**.

5. After the import is complete, a final import status pop-up window will open stating success or failure. Click **OK**.

![Screenshot of Template Provisioning window](image)
**Note** – Windows 7 (and later) locks the Avaya IP Office 9.1 \Templates directory, and it cannot be viewed. To enable browsing of the \Templates directory, open Windows Explorer, navigate to C:\Program Files\Avaya\IP Office\Manager\Templates (or C:\Program Files (x86)\Avaya\IP Office\Manager\Templates), and then click on the Compatibility files option shown below. The \Templates directory and its contents can then be viewed.
5.4.2. Creating a SIP Trunk from an XML Template

1. To create the SIP Trunk from a template, right-click on Line in the Navigation Pane, and select **New SIP Trunk from Template**.

2. In the subsequent **Template Type Selection** pop-up window, from the **Service Provider** pull-down menu, select the XML template name from **Section 5.4.1**. Click **Create new SIP Trunk**.

   **Note** – The drop down menu will display the `<user supplied text>` part of the template file name (see **Section 5.4.1**). If you check the **Display All** box, then the full template file name is displayed.
The newly created SIP Line will appear in the Navigation pane (e.g., SIP Line 17).

It is important that the SIP Line configuration be reviewed and updated if necessary after the SIP Line is created via the template. The resulting SIP Line data can be verified against the manual configuration shown in **Section 5.4.3 – 5.4.8.**
5.4.3. SIP Line – SIP Line Tab

On the SIP Line tab in the Details Pane, configure or verify the parameters as shown below.

- Leave the **ITSP Domain Name** blank. Note that if this field is left blank, then IP Office inserts the far end's ITSP Proxy Address from the Transport tab as the ITSP Domain in the SIP messaging.
- Verify that **URI Type** is set to SIP.
- Verify that **In Service** box is checked, which is the default value. This makes the trunk available to incoming and outgoing calls.
- Verify that **Check OOS** box is checked, the default value. IP Office will use the SIP OPTIONS method to periodically check the SIP Line. The time between SIP OPTIONS sent by IP Office will use the Binding Refresh Time for LAN2, as shown in Section 5.2.1.
- Verify that **Refresh Method** is set to Auto.
- Verify that **Timer (seconds)** is set to On Demand.
- Set **Send Caller ID** to Diversion Header.
- Under Redirect and Transfer, set **Incoming Supervised REFER** and **Outgoing Supervised REFER** to Never (see Section 2.1).

All other parameters should be set to default or according to customer requirements. Click **OK** to commit (not shown).
5.4.4. SIP Line - Transport Tab

Select the Transport tab. Set or verify the parameters as shown below.

- Set ITSP Proxy Address to 10.10.112.6, the IP address of the Service Provider’s SIP Proxy.
- Set Layer 4 Protocol to UDP.
- Set Use Network Topology Info to LAN2. The LAN2 settings correspond to the WAN port on the Avaya IP Office 500v2, used by the SIP Line to access the far-end, configured in Section 5.2.1.
- Set the Send Port to 5060.
- Default values may be used for all other parameters.
- Click OK to commit (not shown).
5.4.5. SIP Line - SIP URI Tab

Two SIP URI entries must be created to match each outgoing number that Avaya IP Office will send on this line and incoming numbers that Avaya IP Office will accept on this line.

To set the SIP URI for outgoing numbers, select the SIP URI tab, then click the Add button and the New Channel area will appear at the bottom of the pane. To edit an existing entry, click an entry in the list at the top, and click the Edit button. The entry was created with the parameters shown below:

- Set Local URI, Contact, Display Name to Use Internal Data.
- Set PAI to None.
- Set Registration to 1: User123 (Note that this field will default to the User Name used under the SIP Credentials tab).
- Set Incoming Group to 0.
- Set Outgoing Group to 17 (SIP Line number being used).
- Set Max Calls per Channel to the number of simultaneous SIP calls that are allowed using this SIP URI pattern.
- Click OK to commit.
To set the SIP URI for incoming numbers, select the **SIP URI** tab, then click the **Add** button and the **New Channel** area will appear at the bottom of the pane. To edit an existing entry, click an entry in the list at the top, and click the **Edit** button. The entry was created with the parameters shown below:

- Set **Local URI**, **Contact**, and **Display Name** to “*” (asterisk).
- Set **PAI** to **None**.
- Set **Registration** to 0: `<None>`.
- Set **Incoming Group** to 17 (SIP Line number being used).
- Set **Outgoing Group** to 0.
- Set **Max Calls per Channel** to the number of simultaneous SIP calls that are allowed using this SIP URI pattern.
- Click **OK** to commit.
5.4.6. SIP Line - VoIP Tab

Select the VoIP tab, to set the Voice over Internet Protocol parameters of the SIP Line. Set or verify the parameters as shown below.

- Set the Codec Selection to System Default. With this setting the System default codec selection configured under Section 5.2.4 will be used. The Codec Selection can be configured using the Custom option instead, allowing an explicit order of codecs to be specified for the SIP Line. The buttons allow setting the specific order of preference for the codecs to be used on the SIP Line. Since Time Warner Cable only supports codec G.711ULAW for audio, the System Default was used.
- Select G.711 for Fax Transport Support.
- Set the DTMF Support field to RFC2833. This directs IP Office to send DTMF tones as out-band RTP events as per RFC2833.
- Uncheck the VoIP Silence Suppression option box.
- Check the Re-invite Supported option box.
- Verify that Codec Lockdown is unchecked.
- Verify that Allow Direct Media Path is unchecked.
- Check the PRACK/100rel Supported option box. This setting enables support by IP Office for the PRACK (Provisional Reliable Acknowledgement) message on SIP trunks.
- Click the OK to commit (not shown).

Note: The codec selections defined under this section (SIP Line – VoIP tab) are the codecs selected for the SIP Line (Trunk). The codec selections defined under Section 5.2.4 (System – Codec tab) are the codecs selected for the IP phones/extension (H.323 and SIP). Since Time Warner Cable only supports codec G.711ULAW, the Codec Selection was set to use System Default defined under Section 5.2.4.
5.4.7. SIP Line – SIP Credentials Tab

Select the **SIP Credentials** tab, and then click the **Add** button to add the SIP Trunk registration credentials. Set the parameters as show below.

- For **User name**, add the user name credential provided by Time Warner Cable for SIP Trunk registration.
- Set the **Authentication Name** the same as the **User name** above.
- Set the **Contact** the same as the **User name** above.
- For **Password**, add the password credential provided by Time Warner Cable for SIP Trunk registration.
- Set **Expiry (mins)** to a value acceptable to the enterprise. This setting defines how often registration with Time Warner Cable is required following any previous registration. For the compliance test 5 minutes was used.
- Verify that **Registration required** is checked.
- Click the **OK** to commit.
5.4.8. SIP Line – SIP Advanced Tab

Select the **SIP Advanced** tab, no changes are required to be made on the **SIP Advanced** tab, default values are used. Verify that all settings are configured with default values as shown below.
5.5. Outbound Call Routing

For outbound call routing, a combination of system short codes and Automatic Route Selection (ARS) entries are used. With ARS, features like time-based routing criteria and alternate routing can be specified so that a call can re-route automatically if the primary route or outgoing line group is not available. While detailed coverage of ARS is beyond the scope of these Application Notes, and alternate routing was not used in the reference configuration, this section includes some basic screen illustrations of the ARS settings used during the compliance testing.

5.5.1. Short Codes and Automatic Route Selection

To create a short code to be used for ARS, right-click on Short Code on the Navigation Pane and select New. The screen below shows the short code 9N created (note that the semi-colon is not used here). In this case, when the IP Office user dials 9 plus any number N, instead of being directed to a specific Line Group ID, the call is directed to Line Group 50: Main, which is configurable via ARS.

- In the Code field, enter the dial string which will trigger this short code. In this case, 9N was used (note that the semi-colon is not used here).
- Set Feature to Dial. This is the action that the short code will perform.
- Set Telephone Number to N. The value N represents the number dialed by the user after removing the 9 prefix. This value is passed to ARS.
- Set the Line Group ID to 50: Main to be directed to Line Group 50: Main, which is configurable via ARS.
- Click the OK to commit (not shown).
The following screen shows a sample ARS configuration for the route Main. Note the sequence of X’s used in the Code column of the entries to specify the exact number of digits to be expected, following the access code and the first set of digits on the string. This type of setting results in a much quicker response in the delivery of the call by IP Office.

To create a short code to be used for ARS, select ARS → 50: Main on the Navigation Pane and click Add.

- In the Code field, enter the dial string which will trigger this short code. In this case, 1 followed by 10 X’s to represent the exact number of digits.
- Set Feature to Dial. This is the action that the short code will perform.
- Set Telephone Number to 1N. The value N represents the additional number of digits dialed by the user after dialing 1 (The 9 will be stripped off).
- Set the Line Group ID to the Line Group number being used for the SIP Line, in this case Line Group ID 17 was used.
- Set Locale to United States (US English).
- Click OK to commit.

![Edit Short Code](image)

Repeat the above procedure for additional dial patterns to be used by the enterprise to dial out from IP Office.
The example highlighted below shows that for calls in the North American numbering plan, the user dialed 9, followed by 1 and 10 digits (represented by 10 X’s). The 9 is stripped off, the remaining digits, including the 1, are included in the SIP INVITE message IP Office sends to Time Warner Cable.
5.6. User

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP Line defined in Section 5.4. To configure these settings, first navigate to User → Name in the Navigation Pane where Name is the name of the user to be modified. In the example below, the name of the user is Ext3042 H323. Select the SIP tab in the Details Pane. The SIP Name and Contact are set to one of the DID numbers assigned to the enterprise by Time Warner Cable. Note that a “+” sign was added to the DID number for each user under SIP Name and Contact. IP Office will insert the “+” sign in front of the 11 digit number included in the Diversion header on calls that are re-directed to the PSTN, this is required by Time Warner Cable. The SIP Display Name (Alias) parameter can optionally be configured with a descriptive name. If all calls involving this user and a SIP Line should be considered private, then the Anonymous box may be checked to withhold the user’s information from the network. This can also be accomplished by activating Withhold Number on H.323 Deskphones (not shown). Click the OK to commit (not shown).
5.7. Incoming Call Route

An incoming call route maps an inbound DID number on a specific line to an internal extension. This procedure should be repeated for each DID number assigned to IP Office users. To create an incoming call route, right-click **Incoming Call Routes** in the Navigation Pane and select **New**.

5.7.1. Incoming Call Route – Standard Tab

On the **Standard** tab of the Details Pane, enter the parameters as shown below.

- Set the **Bearer Capacity** to **Any Voice**.
- Set the **Line Group Id** to the incoming line group of the SIP line defined in **Section 5.4**.
- Set the **Incoming Number** to the incoming number on which this route should match.
- Default values can be used for all other fields.
5.7.2. Incoming Call Route – Destinations Tab

On the **Destinations** tab, select the destination extension from the pull-down menu of the **Destination** field. Click the **OK** button (not shown).

In this example, incoming calls to 19193781301 on line 17 are routed to extension 3042.
5.8. Save Configuration

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the configuration performed in the preceding sections.

The following will appear, with either Merge or Immediate selected, based on the nature of the configuration changes made since the last save. Note that clicking OK may cause a service disruption. Click OK to proceed.
6. Time Warner Cable Business Class SIP Trunking Service Configuration

To use Time Warner Cable’s SIP Trunking Services, a customer must request the service from Time Warner Cable using the established sales processes. The process can be started by contacting Time Warner Cable via the corporate web site at: http://business.timewarnercable.com/support/overview.html or call 866-892-4249 and requesting information.

During the signup process, Time Warner Cable and the customer will discuss details about the preferred method to be used to connect the customer’s enterprise network to Time Warner Cable’s network.

Time Warner Cable is responsible for the configuration of Time Warner Cable Business Class SIP Trunking Service. The customer will need to provide the public IP address used to reach IP Office at the enterprise. In the case of the compliance test, this is the public IP address of the IP Office WAN port (LAN2).

Time Warner Cable will provide the customer the necessary information to configure IP Office following the steps discussed in the previous sections, including:

- Time Warner Cable’s SIP Proxy IP address.
- SIP Trunk registration credentials.
- Supported codec’s and order of preference.
- DID numbers.
- Etc.
7. Verification Steps

This section provides verification steps that may be performed to verify that the solution is configured properly.

The following steps may be used to verify the configuration:

- Verify that endpoints at the enterprise site can place calls to the PSTN.
- Verify that endpoints at the enterprise site can receive calls from the PSTN.
- Verify that users at the PSTN can end active calls to endpoints at the enterprise by hanging up.
- Verify that endpoints at the enterprise can end active calls to PSTN users by hanging up.

7.1. Avaya IP Office System Status

The following steps can also be used to verify the configuration.

Use the Avaya IP Office System Status application to verify the state of SIP connections. Launch the application from Start → Programs → IP Office → System Status on the PC where Avaya IP Office System Status is installed, log in with the proper credentials.
Select the SIP Line under **Trunks** from the left pane. On the **Status** tab in the right pane, verify the **Current State** is **Idle** for each channel.

Select the **Alarms** tab and verify that no alarms are active on the SIP Line.
Select the **Registration** tab to view the Registration status of the SIP Trunk. Note that the registration status shown below is “Not Registered” since the SIP Trunk registration credential used during the screen capture shown below were invalid (masked) for security reasons, otherwise the status would show as “Registered”.

![IP Office System Status](image)
7.2. Avaya IP Office Sys Monitor

The Avaya IP Office Sys Monitor application can be used to monitor and troubleshoot signaling messaging on the SIP trunk. Launch the application from **Start → Programs → IP Office → Monitor** on the PC where Avaya IP Office Sys Monitor was installed. Click the **Select Unit** icon on the taskbar and select the IP address of the IP Office system under verification.

![Avaya IP Office Sys Monitor - [STOPPED]](image)

- Start/Stop Trace
- Trace Options
- Select Unit
Clicking the **Trace Options** icon on the taskbar, selecting the **SIP** tab allows modifying the threshold used for capturing events, types of packets to be captured, filters, etc. Additionally, the color used to represent the packets in the trace can be customized by right clicking on the type of packet and selecting the desired color.

![Trace Options Icon](image)

**Events**
- Sip
- STUN
- SIP Dect

**Packets**
- SIP Reg/Cx Rx
- SIP Reg/Cx Tx
- SIP Call Rx
- SIP Call Tx
- SIP Rr
- SIP Tx

**IP Filter** (mnn.mnn.mnn.mnn)

**Buttons**
- Default All
- Clear All
- Tab Clear All
- Tab Set All
- Save File
- Load File
- Load Partial File
- Select File

**Interface**
- ATM
- Cell
- DTE
- EConf
- Frame Relay
- GO/D
- H.323
- ISDN
- Key/Comp
- Directory
- Media
- FPP
- R2
- Routing
- Services
- SIP
- System
8. Conclusion

These Application Notes describe the configuration steps necessary for configuring Session Initiation Protocol (SIP) Trunk Service for an enterprise solution consisting of Avaya IP Office Release 9.1 to interoperate with Time Warner Cable Business Class SIP Trunking Service. Time Warner Cable Business Class SIP Trunking Service is a SIP-based Voice over IP solution for customers ranging from small businesses to large enterprises. It provides a flexible, cost-saving alternative to traditional hardwired telephony trunks.

Time Warner Cable Business Class SIP Trunking Service passed compliance testing with the observations/limitations outlined in the scope of testing in Section 2.1 as well as under test results in Section 2.2.

9. References

This section references the documentation relevant to these Application Notes. Product documentation for Avaya IP Office, including the following, is available at:

http://support.avaya.com/


Additional Avaya IP Office documentation can be found at:
http://marketingtools.avaya.com/knowledgebase/
©2015 Avaya Inc. All Rights Reserved.
Avaya and the Avaya Logo are trademarks of Avaya Inc. All trademarks identified by ® and ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners. The information provided in these Application Notes is subject to change without notice. The configurations, technical data, and recommendations provided in these Application Notes are believed to be accurate and dependable, but are presented without express or implied warranty. Users are responsible for their application of any products specified in these Application Notes.

Please e-mail any questions or comments pertaining to these Application Notes along with the full title name and filename, located in the lower right corner, directly to the Avaya DevConnect Program at devconnect@avaya.com.