About Spectrum Enterprise:

Spectrum Enterprise is a division of Charter Communications following a merger with Time Warner Cable and acquisition of Bright House Networks. Spectrum Enterprise is a national provider of scalable, fiber technology solutions. The Spectrum Enterprise portfolio includes networking and managed services solutions, including Internet access, Ethernet and Managed Network Services, Voice, TV and Cloud solutions. Our industry-leading team of experts works closely with clients to achieve greater business success.

About this document:

Spectrum Enterprise assures IP PBX compatibility by conducting interoperability testing to ensure any potential compatibility issues have been resolved prior to installation. Please review the IP PBX configuration instructions in this guide prior to your installation date.

Be advised that this document may contain references to Charter or Charter Business. All references to Charter should be read as Spectrum Enterprise.

Thank you,

Spectrum Enterprise
Application Notes for Configuring Avaya IP Office Release 9.0 to support Charter Communications SIP Trunking Service - Issue 1.0

Abstract

These Application Notes describe the procedures for configuring Session Initiation Protocol (SIP) Trunking on an enterprise solution consisting of Avaya IP Office 9.0, to interoperate with Charter Communications SIP Trunking Service.

The test was performed to verify SIP trunk features including basic calls, call forward (all calls, busy, no answer), call transfer (blind and consult), conference, and voice mail. The calls were placed to and from the PSTN with various Avaya endpoints.

Charter Communications SIP Trunking Service provides PSTN access via a SIP Trunk between the enterprise and the Charter Communications network as an alternative to legacy analog or ISDN-PRI trunks. This approach generally results in lower cost for the enterprise.

Readers should pay attention to Section 2, in particular the scope of testing as outlined in Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases are adequately covered by this scope and results.

Charter Communications is a member of the Avaya DevConnect Service Provider Program. Information in these Application Notes has been obtained through DevConnect compliance testing and additional technical discussions. Testing was conducted via the DevConnect Program at the Avaya Solution and Interoperability Test Lab.
1. Introduction

These Application Notes describe the steps necessary for configuring Session Initiation Protocol (SIP) Trunking service between Charter Communications and an Avaya SIP-enabled enterprise solution.

In the configuration used during the testing, the Avaya SIP-enabled enterprise solution consists of Avaya IP Office 500v2 Release 9.0 (hereafter referred to as IP Office), Avaya IP Office Video Softphone, Avaya Flare® Experience for Windows and Avaya Deskphones, including SIP, H.323, digital, and analog.

As a required component of the Charter Communications SIP Trunking service offering, Charter Communications will install a Modular Access Router at the customer premises (enterprise site). Charter Communications will perform the initial configuration and maintenance as required. The Modular Access Router will be considered Customer Premises Equipment (CPE).

The Charter Communications SIP Trunking Service referenced within these Application Notes is designed for business customers. Customers using this service with the Avaya IP Office solution are able to place and receive PSTN calls via a broadband WAN connection using the SIP protocol. This converged network solution is an alternative to traditional PSTN trunks such as analog and/or ISDN-PRI trunks. This approach generally results in lower cost for the enterprise.

The terms “service provider”, “Charter” or “Charter Communications” will be used interchangeable throughout these Application Notes.

2. General Test Approach and Test Results

The general test approach was to simulate an enterprise site in the Solution & Interoperability Test Lab by connecting IP Office to Charter’s SIP Trunking service via the public Internet, as depicted in Figure 1.

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent to the interoperability of the tested products and their functionalities. DevConnect Compliance Testing is not intended to substitute full product performance or feature testing performed by DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or completeness of a DevConnect member’s solution.

Testing was performed with IP Office 500v2 R9.0, but it also applies to IP Office Server Edition R9.0. Note that IP Office Server Edition requires an Expansion IP Office 500v2 R9.0 to support analog, digital endpoints or trunks.
2.1 Interoperability Compliance Testing

To verify Charter’s SIP Trunking service offering with Avaya IP Office, the following features and functionalities were exercised during the compliance testing:

- Response to SIP OPTIONS queries.
- Incoming PSTN calls to various Avaya endpoints, including SIP, H.323, digital and analog at the enterprise. All incoming calls from the PSTN were routed to the enterprise across the SIP Trunk from the service provider networks.
- Outgoing PSTN calls from Avaya endpoints including SIP, H.323, digital and analog telephone at the enterprise. All outgoing calls to the PSTN were routed from the enterprise across the SIP trunk to the service provider networks.
- Incoming and outgoing PSTN calls to/from Avaya IP Office Video Softphone.
- Incoming and outgoing PSTN calls to/from Avaya Flare® Experience for Windows.
- Dialing plans including long distance, international, outbound toll-free, etc.
- Caller ID presentation and Caller ID restriction.
- Proper disconnect when the caller abandons the call before the call is answered.
- Proper disconnect via normal call termination by the caller or the called parties.
- Proper disconnect by the network for calls that are not answered (with coverage to voicemail off).
- Proper response to busy endpoints.
- Proper response/error treatment when dialing invalid PSTN numbers.
- Codec G.711MU (Charter supported audio codec).
- Proper response to no matching codecs.
- G.711 Fax Pass-through.
- Proper early media transmissions.
- Voicemail and DTMF tone support using RFC 2833 (leaving and retrieving voice mail messages, etc.).
- Outbound Toll-Free calls, interacting with IVR (Interactive Voice Response systems).
- Call Hold/Resume (long and short duration).
- Call Forward (unconditional, busy, no answer).
- Blind Call Transfers.
- Consultative Call Transfers.
- Station Conference.
- Mobility twinning of incoming calls to mobile phones.

Items not supported or not tested included the following:

- The use of the SIP REFER method for network call redirection is not currently supported by Charter.
- Inbound toll-free calls and 911 emergency calls are supported but were not tested as part of the compliance test.
- T.38 fax is not supported by Charter; therefore T.38 fax was not tested, G.711 Fax Pass-through was tested successfully and it’s recommended instead.
2.2 Test Results
Interoperability testing with Charter Communications SIP Trunking service was successfully completed with the exception of observations/limitations described below:

- **No matching codec on outbound calls**: If an unsupported audio codec is received by Charter on the SIP Trunk (e.g., 722), Charter will respond with “404 Not Found” instead of “488 Not Acceptable Here”, the user will hear re-order. This issue does not have any user impact, it is listed here simply as an observation.

- **Call Display on Transferred Calls to the PSTN**: Caller ID display is not updated on PSTN phones involved with call transfers from IP Office to the PSTN. After the call transfer is completed, the PSTN phone does not display the actual connected party but instead shows the number of the host extension that initiated the call transfer (transferor). The PSTN phone display is ultimately controlled by the PSTN provider, thus this behavior is not necessarily indicative of a limitation of the combined Avaya/Charter solution. It is listed here simply as an observation.

2.3 Support
For support on Charter Communications systems visit the corporate Web page at:
https://www.charterbusiness.com/ or call 800-314-7195

Avaya customers may obtain documentation and support for Avaya products by visiting http://support.avaya.com. Alternatively, in the United States, (866) GO-AVAYA (866-462-8292) provides access to overall sales and service support menus.

3. Reference Configuration
Figure 1 illustrates the test configuration used. The test configuration simulates an enterprise site with an Avaya SIP-enabled enterprise solution connected to the Charter Communications SIP trunking service through the public Internet.

The Avaya components used to create the simulated enterprise customer site includes:

- Avaya IP Office 500v2.
- Avaya IP Office Voicemail Pro.
- Avaya 96x0 Series H.323 IP Deskphones.
- Avaya 96x1 Series H.323 IP Deskphones.
- Avaya 1100 Series SIP IP Deskphones.
- Avaya IP Office Video Softphone.
- Avaya Flare® Experience for Windows.
- Avaya 1408 Digital Telephones.
- Avaya 9508 Digital Telephones.

In the reference configuration, a Modular Access Router was required at the simulated enterprise site, acting as a SIP interface between the Avaya enterprise (IP Office) and Charter’s network. Charter Communications will install the Modular Access Router at the customer premises (enterprise site). Charter Communications will perform the initial configuration and maintenance as required. The Modular Access Router will be considered Customer Premises Equipment (CPE).
Also located at the simulated enterprise site is Avaya IP Office 500v2 with analog and digital extension expansion modules, as well as a VCM64 (Voice Compression Module) for supporting VoIP codecs. The IP Office LAN1 port connects to the inside interface (or private side) of Charter’s Modular Access Router.

The transport protocol between IP Office and Charter’s Modular Access Router, across the enterprise private IP network, is SIP over UDP.

For inbound calls, the calls flowed from Charter’s network, across the public Internet, to Charter’s Modular Access Router, then to IP Office.

Outbound calls to the PSTN were first processed by IP Office. Once IP Office selected the proper SIP trunk; the call was routed to Charter’s Modular Access Router, across the public Internet, then to Charter’s network.

For the purposes of the compliance test, users dialed a short code of 9 + N digits to make calls across the SIP trunk to Charter (refer to Section 5.8). The short code 9 was stripped off by Avaya IP Office but the remaining N digits were sent unaltered to the network. Since Charter is a U.S. based company, a country member of the North American Numbering Plan (NANP), the users dialed 7 or 10 digits for local calls, and 11 (1 + 10) digits for other calls between the NANP.

In an actual customer configuration, the enterprise site may also include additional network components between Charter and the enterprise. A complete discussion of the configuration of these devices is beyond the scope of these Application Notes. However, it should be noted that SIP and RTP traffic between the service provider and the enterprise must be allowed to pass through these devices.

For confidentiality and privacy purposes, actual public IP addresses and DID numbers used during the compliance test have been replaced with fictitious IP addresses and DID numbers throughout the Application Notes.
Figure 1: Avaya Interoperability Test Lab Configuration.
4. Equipment and Software Validated

The following equipment and software/firmware were used for the compliance testing.

<table>
<thead>
<tr>
<th>Equipment/Software</th>
<th>Release/Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avaya IP Office 500v2</td>
<td>9.0.4.0 Build 965</td>
</tr>
<tr>
<td>Avaya IP Office DIG DCPx16 V2</td>
<td>9.0.4.0 Build 965</td>
</tr>
<tr>
<td>Avaya IP Office Manager</td>
<td>9.0.4.0 Build 965</td>
</tr>
<tr>
<td>Avaya Voicemail Pro Client</td>
<td>9.0.4.0 Build 18</td>
</tr>
<tr>
<td>Avaya 96x0 IP Deskphones (H.323)</td>
<td>Avaya one-X® Deskphone Edition S3.220A</td>
</tr>
<tr>
<td>Avaya 96x1 Series IP Deskphones (H.323)</td>
<td>Avaya one-X® Deskphone H.323 Version 6.4014</td>
</tr>
<tr>
<td>Avaya 1120E IP Deskphones (SIP)</td>
<td>SIP1120e Ver. 04.04.14.00</td>
</tr>
<tr>
<td>Avaya IP Office Video Softphone</td>
<td>3.2.3.49 68975</td>
</tr>
<tr>
<td>Avaya Flare® Experience for Windows</td>
<td>1.1.4.23</td>
</tr>
<tr>
<td>Avaya Digital Deskphones 1408</td>
<td>38.0</td>
</tr>
<tr>
<td>Avaya Digital Deskphones 9508</td>
<td>0.55</td>
</tr>
<tr>
<td>Lucent Analog Phone</td>
<td>--</td>
</tr>
</tbody>
</table>

**Charter Communications**

<table>
<thead>
<tr>
<th>Equipment/Software</th>
<th>Release/Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Broadworks Broadsoft Application Server</td>
<td>R17 SP4</td>
</tr>
<tr>
<td>ACME Packet 4500 Series SBC</td>
<td>nnSCX6.2.0mp</td>
</tr>
<tr>
<td>Adtran NetVanta 3430 Modular Access Router</td>
<td>R10.3.0.V</td>
</tr>
</tbody>
</table>
5. Configure IP Office

This section describes the IP Office configuration required to interwork with Charter Communications. IP Office is configured through Avaya IP Office Manager (IP Office Manager) which is a PC application. On the PC, select **Start → Programs → IP Office → Manager** to launch IP Office Manager. Navigate to **File → Open Configuration**, select the proper IP Office from the pop-up window, and log in with the appropriate credentials. A management window will appear as shown in the next sections. The appearance of IP Office Manager can be customized using the **View** menu (not shown). In the screenshots presented in this section, the **View** menu was configured to show the **Navigation Pane** on the left side and the **Details Pane** on the right side. These panes will be referenced throughout these Application Notes.

These Application Notes assume the basic installation and configuration of IP Office have already been completed and are not discussed here. For further information on IP Office, please consult References in **Section 9**.

5.1 Licensing

The configuration and features described in these Application Notes require the IP Office system to be licensed appropriately. If a desired feature is not enabled or there is insufficient capacity, contact an authorized Avaya sales representative.

To verify that there is a SIP Trunk Channels License with sufficient capacity; click **License** in the Navigation pane and **SIP Trunk Channels** in the Group pane. Confirm that there is a valid license with sufficient “Instances” (trunk channels) in the Details pane. Note that the full License Keys in the screen below is not shown for security purposes.
5.2 System
Configure the necessary system settings. In an Avaya IP Office the LAN2 tab settings correspond to the Avaya IP Office WAN port (public network side) and the LAN1 tab settings correspond to the LAN port (private network side). For the compliance test, the LAN1 interface was used to connect Avaya IP Office to the enterprise private network (LAN), LAN2 was not used.

5.2.1 System - LAN1 Tab
In the sample configuration, the MAC address **00E00706530F** was used as the system name. The LAN port connects to Charter’s Modular Access Router, across the enterprise LAN (private) network. The LAN1 settings correspond to the LAN port in IP Office. To access the LAN1 settings, navigate to System (1) → **00E00706530F** in the Navigation Pane then in the Details Pane navigate to the LAN1 → LAN Settings tab. The LAN1 settings for the compliance testing were configured with following parameters.

- Set the **IP Address** field to the LAN IP address, e.g. **172.16.5.60**.
- Set the **IP Mask** field to the subnet mask of the public network, e.g. **255.255.255.0**.
- All other parameters should be set according to customer requirements.
- Click **OK** to commit (not shown).

![LAN1 Configuration](image.png)
The VoIP tab as shown in the screenshot below was configured with following settings.

- Check the **H323 Gatekeeper Enable** to allow Avaya IP Telephones/Softphone using the H.323 protocol to register.
- Check the **SIP Trunks Enable** to enable the configuration of SIP Trunk connecting to Charter Communications.
- Check the **SIP Registrar Enable** to allow Avaya IP Telephones/Softphone to register using the SIP protocol.
- Enter the Domain Name of the enterprise under **Domain Name**.
- Verify the **UDP Port** and **TCP Port** numbers under **Layer 4 Protocol** are set to **5060**.
- Verify the **RTP Port Number Range** settings for a specific range for the RTP traffic. The **Port Range (Minimum)** and **Port Range (Maximum)** values were kept as default.
- In the **Keepalives** section at the bottom of the page, set the **Scope** field to **RTP, Periodic Timeout to 30**, and **Initial keepalives to Enabled**. This will cause the IP Office to send RTP keepalive packets at the beginning of the calls and every 30 seconds thereafter if no other RTP traffic is present.
- All other parameters should be set according to customer requirements.
- Click **OK** to commit (not shown).
In the **Network Topology** tab, configure the following parameters:

- Select the **Firewall/NAT Type** from the pull-down menu to the option that matches the network configuration. In the compliance testing, it was set to **Open Internet**. With this configuration, even though the default STUN settings are populated, they will not be used.
- Set the **Binding Refresh Time (seconds)** to a desired value, the value of **300 (or every 5 minutes)** was used during the compliance testing. This value is used to determine the **frequency** that IP Office will send OPTIONS heartbeat to the service provider.
- Verify the **Public IP Address** is set to **0.0.0.0**.
- Set the **Public Port** to **5060** for **UDP**.
- All other parameters should be set according to customer requirements.
- Click **OK** to commit (not shown).
5.2.2 System - Telephony Tab

Navigate to the **Telephony → Telephony** Tab in the Details Pane, configure the following parameters:

- Choose the **Companding Law** typical for the enterprise location, **U-Law** was used.
- Uncheck the **Inhibit Off-Switch Forward/Transfer** box to allow call forwarding and call transfers to the PSTN via the SIP trunk to the service provider.
- All other parameters should be set according to customer requirements.
- Click **OK** to commit (not shown).
5.2.3 System - Twinning Tab

Navigate to the Twinning tab on the Details Pane, configure the following parameters:

- Uncheck the Send original calling party information for Mobile Twinning box. This will allow the Caller ID for Twinning to be controlled by the setting on the SIP Line (Section 5.4). This setting also impacts the Caller ID for call forwarding.
- Click OK to commit (not shown).
5.2.4 System - Codecs Tab

For Codec’s settings, navigate to the **System (1) ➔ 00E00706530F** in the Navigation Pane, select the **Codecs** tab and configure the following parameters:

- The **RFC2833 Default Payload** field is new in IP Office release 9.0. It allows the manual configuration of the payload type used on SIP calls that are initiated by the IP Office. The default value **101** was used.
- For **Codec Selection**, select the codecs and codec order of preference on the right, under the **Selected** column. The **Default Codec Selection** area enables the codec preference order to be configured on a system-wide basis. The buttons between the two lists can be used to move codecs between the **Unused** and **Selected** lists, and to change the order of the codecs in the **Selected** codecs list. By default, all IP lines and phones (SIP and H.323) will use the system default codec selection shown here, unless configured otherwise for a specific line or extension. The example below shows the codecs used for IP phones (SIP and H.323).
- Click **OK** to commit (not shown).

The **Codec’s** settings are shown in the screenshot below with **G.711ULAW, G.711ALAW and G.729(a)** selected in prioritized order.

<table>
<thead>
<tr>
<th>IP Offices</th>
<th>00E00706530F</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>System (1)</strong></td>
<td><strong>Codec</strong></td>
</tr>
<tr>
<td><strong>RFC2833 Default Payload</strong></td>
<td><strong>101</strong></td>
</tr>
<tr>
<td><strong>Available Codecs</strong></td>
<td><strong>G.711 ULAW/64K</strong></td>
</tr>
<tr>
<td><strong>G.711 ALAW/64K</strong></td>
<td><strong>G.722 64K</strong></td>
</tr>
<tr>
<td><strong>G.722(2) G.722</strong></td>
<td><strong>G.723 8K</strong></td>
</tr>
<tr>
<td><strong>G.723(2) G.723(2) G.723(2)</strong></td>
<td><strong>G.723(2) G.723(2) G.723(2)</strong></td>
</tr>
</tbody>
</table>

**Note:** The codec selections defined under this section (System – Codecs Tab) are the codecs selected for the IP phones/extensions. The codec selections defined under **Section 5.4.5** (SIP Line – VoIP tab) are the codecs selected for the SIP Line (Trunk).
5.3 IP Route

In the reference configuration, the IP Office LAN1 interface and the private interface of the Charter’s Modular Access Router resided on the same IP subnet, so an IP route was not necessary. In an actual customer configuration, these two interfaces may be in different IP subnets, and in that case an IP route would have to be created to specify the IP address of the gateway or router where the IP Office needs to send the packets, in order to reach the IP subnet where the Charter Modular Access Router resides.

To create an IP route to specify the IP address of the gateway or router where the IP Office needs to send the packets in order to reach the IP subnet where the Charter Modular Access Router resides (if located in different subnets), on the left navigation pane, right-click on IP Route and select New.

- Set the **IP Address** and **IP Mask** of the subnet of the private side of Charter’s Modular Access Router, or enter **0.0.0.0** to make this the default route.
- Set **Gateway IP Address** to the IP Address of the default router in the IP Office subnet.
- Set **Destination** to **LAN1** from the pull-down menu.
- Click **OK** to commit (not shown).
5.4 SIP Line

A SIP line is needed to establish the SIP connection between Avaya IP Office and the Charter Communications SIP Trunk Service. The recommended method for configuring a SIP Line is to use the template associated with these Application Notes. The template is an .xml file that can be used by IP Office Manager to create a SIP Line. Follow the steps in Section 5.4.1 to create the SIP Line from the template.

Some items relevant to a specific customer environment are not included in the template or may need to be updated after the SIP Line is created. Examples include the following:

- IP addresses.
- SIP Credentials (if applicable).
- SIP URI entries.
- Setting of the Use Network Topology Info field on the Transport tab.

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary after the SIP Line is created via the template. The resulting SIP Line data can be verified against the manual configuration shown in Sections 5.4.2 – 5.4.5.

Also, the following SIP Line settings are not supported on Basic Edition:

- SIP Line – Originator number for forwarded and twinning calls.
- SIP Credentials – Registration Required.

Alternatively, a SIP Line can be created manually. To do so, right-click on Line in the Navigation Pane and select New  SIP Line. Then, follow the steps outlined in Sections 5.4.2 – 5.4.5.
5.4.1 SIP Line From Template

1. Copy the template file to the computer where IP Office Manager is installed. If needed, rename the template file to US_Charter_SIPTrunk.xml. The file name is important in locating the proper template file in Step 5.

2. Verify that template options are enabled in IP Office Manager. In IP Office Manager, navigate to File → Preferences. In the IP Office Manager Preferences window that appears, select the Visual Preferences tab. Verify that the box is checked next to Enable Template Options. Click OK.
3. Import the template into IP Office Manager. From IP Office Manager, select **Tools → Import Templates in Manager**. This action will copy the template file into the IP Office template directory and make the template available in the IP Office Manager pull-down menus in **Step 5**. The default template location is **C:\Program Files\Avaya\IP Office\Manager\Templates**.

4. In the pop-up window (not shown) that appears select the directory where the template file was copied in **Step 1**. After the import is complete, a final import status pop-up window (not shown) will appear stating success or failure. Click **OK** (not shown) to continue. If preferred, this step may be skipped if the template file is copied directly to the IP Office template directory.
5. To create the SIP Trunk from the template, right-click on Line in the Navigation Pane, then navigate to New → New SIP Trunk From Template.

6. In the subsequent Template Type Selection pop-up window, select United States from the Country pull-down menu and select Charter from the Service Provider pull-down menu as shown below. These values correspond to parts of the file name (US_Charter_SIPTrunk.xml) created in Step 1. Click Create new SIP Trunk to finish creating the trunk.

Once the SIP Line is created, verify the configuration of the SIP Line with the configuration shown in Sections 5.4.2 – 5.4.5.

Alternatively, a SIP Line can be created manually with the parameters shown below. To create a SIP line manually, begin by navigating to Line in the Navigation Pane. Right-click and select New → SIP Line.
5.4.2 SIP Line - SIP Line Tab

On the **SIP Line** tab in the Details Pane, configure the parameters as shown below:

- Set **ITSP Domain Name** to the IP address of the inside interface (or private side) assigned to Charter’s Modular Access Router, as shown on **Figure 1**.
- Verify that the **In Service** box is checked.
- Verify that the **Check OOS** box is checked. With this option selected, IP Office will use the SIP OPTIONS method to periodically check the SIP Line.
- Verify that **Call Routing Method** is set to **Request URI**.
- Set **Send Caller ID** to **Diversion Header**.
- Uncheck the **REFER support** box. The use of the SIP REFER method for network call redirection is not currently supported by Charter (refer to **Section 2.1**)  
- Default values may be used for all other parameters.
- **Click OK** to commit (not shown).
5.4.3 SIP Line - Transport Tab

Select the **Transport** tab; configure the parameters as shown below:

- Set the **ITSP Proxy Address** to the IP address of the inside interface (or private side) assigned to Charter’s Modular Access Router, as shown on **Figure 1**.
- Set the **Layer 4 Protocol** to **UDP**.
- Set **Use Network Topology Info** to **LAN1** as configured in **Section 5.2**.
- Set the **Send Port** to **5060**.
- Default values may be used for all other parameters.
- Click **OK** to commit (not shown).

---

**Table:**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ITSP Proxy Address</td>
<td>172.16.5.185</td>
</tr>
<tr>
<td>Layer 4 Protocol</td>
<td>UDP</td>
</tr>
<tr>
<td>Use Network Topology Info</td>
<td>LAN1</td>
</tr>
<tr>
<td>Send Port</td>
<td>5060</td>
</tr>
<tr>
<td>Explicit DNS Server(s)</td>
<td>0.0.0.0</td>
</tr>
<tr>
<td>Calls Route via Registrar</td>
<td>Y (on)</td>
</tr>
<tr>
<td>Separate Registrar</td>
<td></td>
</tr>
</tbody>
</table>

---

**Diagram:** [Image of SIP Line - Transport Tab configuration]
5.4.4 SIP Line - SIP URI Tab

A SIP URI entry needs to be created to match each incoming number that Avaya IP Office will accept on this line. Select the SIP URI tab, and then click the Add button and the New Channel area will appear at the bottom of the pane. To edit an existing entry, click an entry in the list at the top, and click the Edit… button. In the example screen below, a previously configured entry was edited. For the compliance test, a single SIP URI entry was created that matched any DID number assigned to an Avaya IP Office user. The entry was created with the parameters shown below:

- Set Local URI, Contact, Display Name to Use Internal Data.
- Set PAI to None.
- Associate this line with an incoming line group by entering a line group number in the Incoming Group field. This line group number will be used in defining incoming call routes for this line. Similarly, associate the line to an outgoing line group using the Outgoing Group field. The outgoing line group number is used in defining short codes for routing outbound traffic to this line. For the compliance test, a new incoming and outgoing group 17 was defined that only contains this line (line 17).
- Set Max Calls per Channel to the number of simultaneous SIP calls that are allowed using this SIP URI pattern.
- Click OK.
- Click OK again to commit (not shown).
Additional SIP URIs may be required to allow inbound calls to numbers not associated with a user, such as a short code. These URIs are created in the same manner as shown above with the exception that the incoming DID number is entered directly in the Local URI, Contact, and Display Name fields.

5.4.5 SIP Line - VoIP Tab
Select the VoIP tab to set the Voice over Internet Protocol parameters of the SIP line. Set the parameters as shown below:

- In the sample configuration, the Codec Selection was configured using the Custom option, allowing an explicit order of codecs to be specified for the SIP Line. The buttons allow setting the specific order of preference for the codecs to be used on the SIP Line, as shown. Charter only supports codec G.711ULAW for audio.
- Select G.711 for Fax Transport Support (Refer to Section 2.1).
- Set the DTMF Support field to RFC2833. This directs Avaya IP Office to send DTMF tones using RTP events messages as defined in RFC2833.
- Verify that Allow Direct Media Path is unchecked. Testing was done with Direct Media disabled.
- Check the Re-invite Supported box to allow for codec re-negotiation in cases where the target of an incoming call or transfer does not support the codec originally negotiated on the trunk.
- Check the PRACK/100rel Supported box, to advertise the support for reliable provisional responses and Early Media to Charter Communications.
- Default values may be used for all other parameters.
- Click OK to commit (not shown).
**Note:** The codec selections defined under this section (SIP Line – VoIP tab) are the codecs selected for the SIP Line (Trunk). The codec selections defined under **Section 5.2.4** (System – Codecs tab) are the codecs selected for the IP phones/extension (H.323 and SIP).

### 5.5 Extension

In this section, an example of an Avaya IP Office Extension will be illustrated. In the interests of brevity, not all users and extensions will be presented, since the configuration can be easily extrapolated to other users and extensions. To add an Extension, right click on **Extension** then select **New → Select H323 or SIP**.

Select the **Extn** tab. Following is an example of extension 3040; this extension corresponds to an H.323 extension.
Select the **VOIP** tab. Use default values on VoIP tab. Following is an example for Extension 3040; this extension corresponds to an H.323 extension.

By default, all IP phones (SIP and H.323) will use the system default codec selection configured under the System Codecs tab (**Section 5.2.4**), unless configured otherwise for a specific extension by selecting **Custom** under **Codec Selection** on the screenshot shown below. The example below shows the codecs used for IP phones (SIP and H.323).
5.6 Users
Configure the SIP parameters for each user that will be placing and receiving calls via the SIP line defined in Section 5.4. To configure these settings, first navigate to User in the left Navigation Pane, and then select the name of the user to be modified in the center Group Pane. In the example below, the name of the user is **Ext3040 H323**.
In the example below, the name of the user is “Ext3047 SIP”. This is an Avaya IP Office Softphone user, set the Profile to **Power User** and check **Enable Softphone**.
Select the **Voice Mail** tab. The following screen shows the **Voicemail** tab for the user with extension 3040. The **Voicemail On** box is checked. Voicemail password can be configured using the **Voicemail Code** and **Confirm Voicemail Code** parameters. In the verification of these Application Notes, incoming calls from Charter Communications to this user were redirected to Voicemail Pro after no answer. Voicemail messages were recorded and retrieved successfully. Voice mail navigation and retrieval were performed locally and from PSTN telephones to test DTMF using RFC 2833.

![Voicemail Tab Screenshot]

Select the **Mobility** tab. In the sample configuration user 3040 was one of the users configured to test the Mobile Twinning feature. The following screen shows the **Mobility** tab for User 3040. The **Mobility Features** and **Mobile Twinning** boxes are checked. The **Twinned Mobile Number** field is configured with the number to dial to reach the twinned telephone, including the dial access code “9”, in this case **917863311234**. Other options can be set according to customer requirements.
To program a key on the telephone to turn Mobil Twinning on and off, select the **Button Programming** tab on the user, then select the button to program to turn Mobil Twinning on and off, click on **Edit → Emulation → Twinning** (not shown). In the sample below, button 4 was programmed to turn Mobil Twinning on and off on user 3040.

Select the **SIP** tab, the values entered for the **SIP Name** and **Contact** fields are used as the user part of the SIP URI in the “From” and “Contact” headers for outgoing SIP trunk calls. In addition, these settings are used to match against the SIP URI of incoming calls without having to enter this number as an explicit SIP URI for the SIP line (**Section 5.4**). The example below shows the settings for user “Ext3040 H323”. The **SIP Name** and **Contact** are set to one of the DID numbers assigned to the enterprise by Charter. In the example, DID number **7206341090** was used. The **SIP Display Name** (**Alias**) parameter can optionally be configured with a descriptive name.

If all calls involving this user should be considered private, then the **Anonymous** box may be checked to withhold the Caller ID information from the network.
5.7 Incoming Call Route

An incoming call route maps inbound DID numbers on a specific line to internal extensions, hunt groups, short codes, etc., within the IP Office system.

In a scenario like the one used for the compliance test, only one incoming route is needed, which allows any incoming number arriving on the SIP trunk to reach any predefined extension in IP Office. The routing decision for the call is based on the parameters previously configured for Call Routing Method and SIP URI (Section 5.4) and the users SIP Name and Contact, already populated with the assigned Charter Communications DID numbers (Section 5.6).

From the left Navigation Pane, right-click on Incoming Call Route and select New. On the Details Pane (not shown), under the Standard tab, set the parameters as show bellow:

- Set Bearer Capacity to Any Voice.
- Set the Line Group Id to the incoming line group of the SIP line defined in Section 5.4.
- Default values may be used for all other parameters.
- Under the **Destinations** tab, enter “:” for the **Default Value**. This setting will allow the call to be routed to any destination with a value on its **SIP Name** field, entered on the **SIP** tab of that **User**, which matches the number present on the user part of the incoming Request URI.
- Click **OK** to commit (not shown).
5.8 Outbound Call Routing

For outbound call routing, a combination of system short codes and Automatic Route Selection (ARS) entries are used. With ARS, features like time-based routing criteria and alternate routing can be specified so that a call can re-route automatically if the primary route or outgoing line group is not available. While detailed coverage of ARS is beyond the scope of these Application Notes, and alternate routing was not used in the reference configuration, this section includes some basic screen illustrations of the ARS settings used during the compliance testing.

5.8.1 Short Codes and Automatic Route Selection

To create the short code used for ARS, right-click on Short Code in the Navigation Pane and select New (not shown). The screen below shows the creation of the short code 9N used in the reference configuration. When the Avaya IP Office users dialed 9 plus any number N, calls were directed to Line Group 50: Main, configurable via ARS and defined next in this section.
The following screen shows the example ARS configuration for the route **Main**. Note the sequence of Xs used in the **Code** column of the entries to specify the exact number of digits to be expected, following the access code and the first digit on the string. This type of setting results in a much quicker response in the delivery of the call by IP Office. The first example highlighted below shows that for calls to area codes in the North American Numbering Plan, the user dialed 9, followed by 11 digits, starting with a 1. The second example highlighted shows a seven digit number (for seven digit local dialing) starting with a 6, the user dialed 9, followed by the local number (e.g., 96341234).
5.9 Privacy/Anonymous Calls
For outbound calls with privacy (anonymous) enabled, Avaya IP Office will replace the calling party number in the “From” and “Contact” headers of the SIP INVITE message with “restricted” and “anonymous” respectively. Avaya IP Office can be configured to use the P-Preferred-Identity (PPI) or P-Asserted-Identity (PAI) header to pass the actual calling party information for authentication and billing. By default, Avaya IP Office will use PPI for privacy. For the compliance test, PAI was used for the purposes of privacy.

To configure Avaya IP Office to use PAI for privacy calls, navigate to User → NoUser in the Navigation Pane. Select the Source Numbers tab in the Details Pane. Click the Add button.

At the bottom of the Details Pane, the Source Number field will appear. Enter SIP_USE_PAI_FOR_PRIVACY. Click OK (not shown).

The SIP_USE_PAI_FOR_PRIVACY parameter will appear in the list of Source Numbers as shown below.
5.10 Save Configuration

When desired, send the configuration changes made in Avaya IP Office Manager to the Avaya IP Office server in order for the changes to take effect.

Navigate to File→Save Configuration in the menu bar at the top left of the screen to save the configuration performed in the preceding sections.

Once the configuration is validated, a screen similar to the following will appear, with either the Merge or the Immediate radio button chosen based on the nature of the configuration changes made since the last save. Note that clicking OK may cause a service disruption due to system reboot. Click OK if desired.
6. Charter Communications SIP Trunk Service Configuration

To use Charter Communication’s SIP Trunking service offering, a customer must request the service from Charter Communications using the established sales processes. The process can be started by contacting Charter Communications via the corporate web site at: https://www.charterbusiness.com/ or by calling 800-314-7195.

During the signup process, Charter Communications and the customer will discuss details about the preferred method to be used to connect the customer’s enterprise network to Charter Communications network. Charter Communications will provide IP addresses, Direct Inward Dialed (DID) numbers to be assigned to the enterprise, etc. This information is used to complete the Avaya IP Office configuration discussed in the previous sections.

As previously noted, as a required component of the Charter Communications SIP Trunking service offering, Charter Communications will install a Modular Access Router at the customer premises (enterprise site). Charter Communications will perform the initial configuration and maintenance as required. The Modular Access Router will be considered Customer Premises Equipment (CPE).
7. Verification and Troubleshooting

This section provides verification steps that may be performed in the field to verify that the solution is configured properly. This section also provides a list of useful troubleshooting tips that can be used to troubleshoot the solution.

7.1 Verification Steps

The following steps may be used to verify the configuration:

- Verify that endpoints at the enterprise site can place calls to PSTN and that calls remain active for more than 35 seconds. This time period is included to verify that proper routing of the SIP messaging has satisfied SIP protocol timers.
- Verify that endpoints at the enterprise site can receive calls from PSTN and that calls can remain active for more than 35 seconds.
- Verify that the user on the PSTN side can end an active call by hanging up.
- Verify that an Avaya endpoint at the enterprise site can end an active call by hanging up.

7.2 Protocol Traces

The following SIP message headers are inspected using sniffer trace analysis tool:

- Request-URI: Verify the request number and SIP domain.
- From: Verify the display name and display number.
- To: Verify the display name and display number.
- P-Asserted-Identity: Verify the display name and display number.
- Privacy: Verify privacy masking with “user, id”.
- Diversion: Verify the display name and display number.

The following attributes in SIP message body are inspected using sniffer trace analysis tool:

- Connection Information (c line): Verify IP addresses of near end and far end endpoints.
- Time Description (t line): Verify session timeout value of near end and far end endpoints.
- Media Description (m line): Verify audio port, codec, DTMF event description.
- Media Attribute (a line): Verify specific audio port, codec, ptime, send/receive ability, DTMF events.
7.3 IP Office System Status
The following steps can also be used to verify the configuration.

Use the Avaya IP Office System Status application to verify the state of SIP connections. Launch the application from Start → Programs → IP Office → System Status on the PC where IP Office Manager is installed, log in with the proper credentials.
- Select the SIP Line of interest from the left pane. On the Status tab in the right pane, verify that the Current State is Idle for each channel (assuming no active calls at present time).

- Select the Alarms tab and verify that no alarms are active on the SIP Line.
7.4 IP Office Monitor

The Avaya IP Office Monitor application can be used to monitor and troubleshoot signaling messaging on the SIP trunk. Launch the application from Start → Programs → IP Office → Monitor on the PC where Avaya IP Office Manager was installed. Click the Select Unit icon on the taskbar and Select the IP address of the IP Office system under verification.

![Avaya IP Office Monitor Interface](image)

Clicking the Trace Options icon on the taskbar and selecting the SIP tab allows modifying the threshold used for capturing events, types of packets to be captured, filters, etc. Additionally, the color used to represent the packets in the trace can be customized by right clicking on the type of packet and selecting to the desired color.
## All Settings

<table>
<thead>
<tr>
<th>T1</th>
<th>VComp</th>
<th>VPN</th>
<th>WAN</th>
<th>SDN</th>
<th>SSI</th>
<th>Jado</th>
<th>ATM</th>
<th>Call</th>
<th>DTE</th>
<th>ECont</th>
<th>Frame Relay</th>
<th>G.703</th>
<th>H.323</th>
<th>Interface</th>
<th>ISDN</th>
<th>Key/Lamp</th>
<th>Directory</th>
<th>Media</th>
<th>PPP</th>
<th>R2</th>
<th>Routing</th>
<th>Services</th>
<th>SIP</th>
<th>System</th>
</tr>
</thead>
</table>

### Events

- [ ] Sip

### Packets

- [ ] SIP Reg/Opt Rx
- [ ] SIP Reg/Opt Tx
- [ ] SIP Call Rx
- [ ] SIP Call Tx
- [ ] Call
- [ ] Call Notify Rx
- [ ] Call Notify Tx

**SIP Rx** > *hex*

**SIP Tx** > *hex*

**IP Filters (mm:mm:mm:mm:mm):**

*Input field*

**Default All** | **Clear All** | **Tab Clear All** | **Tab Set All** | **OK** | **Cancel**

**Save File** | **Load File** | **Load Partial File** | **Select File**

---

©2014 Avaya Inc. All Rights Reserved.
8. Conclusion

These Application Notes describe the procedures required to configure SIP trunk connectivity between Avaya IP Office 9.0 and Charter Communications SIP Trunking Service, as shown in Figure 1.

Interoperability testing was completed successfully with the observations/limitations outlined in the scope of testing in Section 2.1 as well as under test results in Section 2.2.
9. References

This section references the documentation relevant to these Application Notes. Product documentation for Avaya IP Office, including the following, is available at:

http://support.avaya.com/


Additional Avaya IP Office documentation can be found at:

http://marketingtools.avaya.com/knowledgebase/
©2014 Avaya Inc. All Rights Reserved.
Avaya and the Avaya Logo are trademarks of Avaya Inc. All trademarks identified by ® and ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners. The information provided in these Application Notes is subject to change without notice. The configurations, technical data, and recommendations provided in these Application Notes are believed to be accurate and dependable, but are presented without express or implied warranty. Users are responsible for their application of any products specified in these Application Notes.

Please e-mail any questions or comments pertaining to these Application Notes along with the full title name and filename, located in the lower right corner, directly to the Avaya DevConnect Program at devconnect@avaya.com.